Software >> OS >> Unix >> Solaris >> 11 >> How to configure name resolution by DNS nameserver in /etc/resolv.conf and /etc/nsswitch.conf

These should not be configured by hand but by using svccfg

resolv.conf

example

# svcs -a | grep dns
 disabled Nov_12 svc:/network/dns/multicast:default
 disabled Nov_12 svc:/network/dns/server:default
 online Nov_12 svc:/network/dns/client:default
# svccfg -s dns/client
 svc:/network/dns/client> listprop config
 config application
 config/value_authorization astring solaris.smf.value.name-service.dns.client
 config/nameserver net_address 10.4.5.254 10.4.6.253
 svc:/network/dns/client> setprop config/nameserver = (10.1.2.254 10.1.2.254)
 svc:/network/dns/client> setprop config/domain = sing.seagate.com
 svc:/network/dns/client> listprop config
 config application
 config/value_authorization astring solaris.smf.value.name-service.dns.client
 config/nameserver net_address 10.1.2.254 10.1.2.254
 config/domain astring sing.seagate.com
 svc:/network/dns/client> exit

nsswitch.conf

# svccfg -s name-service/switch
svc:/system/name-service/switch> setprop config/host = “files dns”
svc:/system/name-service/switch> setprop config/ipnode = astring: “files dns”
svc:/system/name-service/switch> exit
 # svcadm refresh name-service/switch
 # svcadm restart name-service/switch