Create an install service from a downloaded ISO file, specifying x86 based DHCP
client starting at address 192.168.1.210 with a total count of 10 addresses:
Apply a criteria that all clients must have 4096MB memory or greater to the manifest s11manifest of s11x86 service:
# installadm set-criteria -m s11manifest -n s11x86 -a MEM="4096-unbounded"
SYSTEM CONFIGURATION
Common system configuration tasks have changed in Oracle Solaris 11 with the Service Management Facility (SMF) configuration repository being used to store configuration data. With the addition of configuration layers, administrators now have better control and assurance that their configuration changes will be preserved across system updates.
Unconfigure a system and start an interactive configuration tool on reboot:
# sysconfig configure -s
Create a system configuration profile:
# sysconfig create-profile -o sc-profile.xml
Configure a system according to a system configuration profile:
# sysconfig configure -c sc-profile.xml
USERS and GROUPS
The traditional root account has been changed to a 'root' role on all Oracle Solaris 11 installations as part of the Role Based Access Control (RBAC) feature set. This change gives improved auditability across the operating system, and the ability for administrators to
delegate various system tasks to others in a safe way.
Revert to root as normal user account:
# rolemod –K type=normal root
Configure root as a role (default):
# usermod –K type=role root
Add a new user and delegate him the System Adminstrator profile:
Boot Environments are individual bootable instances of the operating system that take advantage of the Oracle Solaris ZFS filesystem snapshot and clone capability. During a system update, new boot environments are created so that system software updates can be applied in a safe environment. Should anything go awry, administrators can boot back into an older boot environment. Boot environments have low overhead and can be quickly created giving administrators an ideal best practice for any system maintenance work.
Create a boot environment:
# beadm create solaris-05032012
Activate a boot environment:
# beadm activate solaris-05032012
Delete a boot environment:
# beadm destroy solaris-05032012
Show boot environments from SPARC boot PROM:
ok boot -L
Boot into a boot environment from SPARC boot PROM:
ok boot -Z rpool/ROOT/solaris-05032012
PACKAGING
Oracle Solaris 11 includes IPS, a new network-centric package management framework with automatic dependency checking. IPS has integrated package and patching, and can seamlessly manage system updates to Oracle Solaris Zones environments.
Install a package called diagnostic/wireshark:
# pkg install diagnostic/wireshark
Install a group package to provide a desktop environment:
# pkg install solaris-desktop
Update all possible packages to the newest version, including any zones:
# pkg update
Do a dry run of a system update to understand what packages may change:
# pkg update -nv
Uninstall a package called diagnostic/wireshark:
# pkg uninstall wireshark
List all packages installed on a system:
# pkg list
Get more information about an installed package called diagnostic/wireshark:
# pkg info wireshark
List the contents of an installed package called diagnostic/wireshark:
# pkg contents wireshark
Search all packages in the configured repositories for a file called math.h:
# pkg search math.h
Search for all packages installed on a system that have a dependency on library/libxml2:
Oracle Solaris ZFS is the default root file system on Oracle Solaris 11. ZFS has integrated volume management, preserves the highest levels of data integrity and includes a wide variety of data services such as data deduplication, RAID and data encryption.
Create a ZFS pool with a single disk:
# zpool create testpool c3t2d0
Create a ZFS pool with 3 disks in RAID0 configuration:
# zpool create testpool c3t2d0 c3t3d0 c3t4d0
Create a ZFS pool with 3 disks in RAID1 configuration:
Oracle Solaris Zones provide isolated and secure virtual environments running on a single operating system instance, ideal for application deployment. When administrators create a zone, an application execution environment is produced in which processes are isolated from the rest of the system.
Create a zone with an exclusive IP network stack:
# zonecfg -z testzone
testzone: No such zone configured
Use 'create' to begin configuring a new zone.
zonecfg:testzone> create
zonecfg:testzone> set zonepath=/zones/testzone
zonecfg:testzone> set autoboot=true
zonecfg:testzone> verify
zonecfg:testzone> commit
zonecfg:testzone> exit
List all running zones verbosely:
# zoneadm list -v
List all configured zones:
# zoneadm list -c
List all installed zones:
# zoneadm list -i
Install a zone:
# zoneadm -z testzone install
Boot a zone:
# zoneadm -z testzone boot
List configuration about a zone:
# zoneadm -z testzone list
Login to a zone:
# zlogin -C testzone
Halt a zone
# zoneadm -z testzone halt
Shutdown a zone
# zoneadm -z testzone shutdown
Monitor a zone for CPU, memory and network utilization every 10 seconds:
# zonestat -z testzone 10
Service Management Facility
Service Management Facility (SMF) provides a framework for managing services on Oracle Solaris including the ability to automatically restart any service after failure. Each service instance is named with a fault management resource indicator (FMRI).
Show all services (including disabled services):
# svcs
List detailed information about system/zones:
# svcs -l system/zones
List processes associated with the network/netcfg service:
# svcs -p network/netcfg
Show why services that are enabled but are not running, or preventing other services from running:
# svcs -xv
Enable a service called network/dns/client:
# svcadm enable network/dns/client
Restart a service called network/nfs/server using an abbreviated FMRI:
# svcadm restart nfs/server
Disable a service called network/ssh:
# svcadm disable network/ssh
Display all properties and values in the SMF configuration repository for the service network/ssh:
# svcprop network/ssh
Interactively display the general/enabled property within the SMF configuration repository for the service network/ssh:
List all configuration changes that have been made in the SMF configuration repository to the name-service/switch service:
# svccfg -s name-service/switch listcust –L
NETWORKING
Oracle Solaris 11 uses profile based networking configuration, comprised of two configuration modes - manual and automatic. These modes differ in how administrators configure the system, either manually using dladm and ipadm, or through creating and applying network configuration profiles.
Networking – Manual Administration
Switch to manual network configuration:
# netadm enable –p ncp defaultfixed
Show physical network interfaces:
# dladm show-phys Create interface with static IPv4 configuration: