This procedure will create local repository that will act as Repository Server for other Solaris 11 hosts.
Copy the Solaris 11.3 GA repository files:
zfs create -o mountpoint=/IPS rpool/IPS
mkdir -p /IPS/repo
unzip -qq sol-11_3-repo_1of5.zip -d /IPS/repo
unzip -qq sol-11_3-repo_2of5.zip -d /IPS/repo
unzip -qq sol-11_3-repo_3of5.zip -d /IPS/repo
unzip -qq sol-11_3-repo_4of5.zip -d /IPS/repo
unzip -qq sol-11_3-repo_5of5.zip -d /IPS/repo
IF AVAILABLE, update SRU (Support Repository Updates):
cd /var/tmp
unzip -qq p25164977_1100_SOLARIS86-64_1of4.zip
unzip -qq p25164977_1100_SOLARIS86-64_2of4.zip
unzip -qq p25164977_1100_SOLARIS86-64_3of4.zip
unzip -qq p25164977_1100_SOLARIS86-64_4of4.zip
pkgrecv -s publisher/solaris -d /IPS/repo/publisher/solaris '*'
rm -fr publisher/ Create repository server:
svccfg -s application/pkg/server setprop pkg/inst_root=/IPS/repo
svccfg -s application/pkg/server setprop pkg/readonly=true
svcadm refresh application/pkg/server
svcadm enable application/pkg/server
pkg set-publisher -O http://192.168.100.100 solaris
Update repository server, if it is necessary:
pkg list -af entire
pkg update --accept entire
beadm list
shutdown -y -g0 –r
Configure and update the client using HTTP repository server:
pkg set-publisher -O http://192.168.100.100 solaris
pkg publisher
pkg list -af entire
pkg update --accept entire
beadm list
shutdown -y -g0 –r
The IP 192.168.100.100 must be replaced by IP of desired Repository Server
|